Samsung Galaxy J5 (2016) Forum

APN Settings not saving

This is an odd issue, I have a Samsung J5 (2016) factory unlocked phone and about 3 days ago I stopped being able to send/receive MMS. I knew that the issue was related to the APN, so I checked the settings and double checked the settings made one correction and saved the settings. When I backed out to check that the phone was using the correct APN (there were like 10+ from the factory) the one I just edited was no longer there. I proceeded to create a new one and saved the settings, went to enable it and it also was not there! I just did a factory reset of the phone and repeated the whole thing of creating/editing the APN with the exact same results. At this point in time I am completely lost as to WTF to do next. Google search came up with a few solutions including rooting the device, which I am not ready to do yet. One of the other options stated that the default APN was corrupt and to download an app from the play store to rebuild it, I have not tried this yet. Can anyone give me some guidance as to what to do next? Thanks
 

Related:

#1 jnelsoninjax, Feb 14, 2018
Have you tried using a different messaging app? Try using Textra and send a MMS and post your results.
It may not be a APN setting.
 
#2 Dannydet, Feb 15, 2018 at 7:06 AM
Hi, thanks for the reply and suggestion! It turns out after two phone calls to Samsung I learned 3 things: 1) The phone in question is not even supported in the USA, it is an Asian market phone, which is odd considering Fingerhut sells it.
2) After doing some more troubleshooting I chatted up the carriers support department and found out that they have two different types of SIM's that they use, GMSA and GSMT (AT&T, and T-Mobile) and that I had previously been given some wrong information which included downloading the Redpocket Mobile app and allowing it to set the APN settings, apparently the app only works on the GSMA SIM cards (which I have another phone with) and the GSMT uses different settings. So after creating a new APN with the correct addresses it saved!
Then I discovered the third thing, the plan I had on this phone only has 500mbs of mobile data (everywhere I go mostly has WiFi) and after doing troubleshooting with support it turns out that the 500Mbs of data was used up, and to send/receive MMS uses mobile data, regardless if you are connected to a WiFI, which I had never heard before, can anyone confirm this to be true or not? Regardless, the outcome is now the phone is working and it is sending and receiving MMS messages.
 
#3 jnelsoninjax, Feb 16, 2018 at 6:20 AM