Nexus 5 Forum

Support Cannot use public WiFi networks.

Hello everyone, I'm new to the forums and already have a problem, I will include as much detail as possible but feel free to ask for more, all help is appreciated!

So the other week I was at a Premier Inn (UK hotel chain) and I was trying to access their free WiFi in the lobby. I clicked the "log-in to network" button within my notification bar and went through the usual steps of logging in with my preexisting account to be met with a large red pad pock with a over the top of it. If you cannot see the Emoji it is the red circle with the line diagonally over it. Then last Thursday I was in a restaurant trying to use their WiFi and it happened again, I cannot find help on the internet anywhere but I haven't given up hope. I go out places often and want to use their WiFi and can't and its very frustrating.

I know it is not the establishments WiFi at fault as my sisters iPhone 5C connects fine, can anyone offer help? I am using a a Nexus 5 2013.

Thanks
 

Related:

#1 YaBoiSloopy, May 30, 2015
Not sure but some will require you use your browser after logging on to their network to agree to their terms of use. I had this happen a few times.
 
#2 argedion, May 30, 2015
I thought it may have something to do with Chrome, hopefully someone else might have the problem.
 
#3 YaBoiSloopy, May 30, 2015
Make sure that Data Saver is off in Chrome.
 
#4 EarlyMon, May 30, 2015
It's off, I believe it has been a while. Will have to see if it makes any difference.
 
#5 YaBoiSloopy, May 30, 2015
I have the same problem with my nexus 5.

All premier inns I've stayed in do the same.
Connects to the WiFi OK but when I click in the sign into network bit it loads it up but after a second I'm faced with a red circle with a line through it as said above.

My data saver is off also
 
#6 Deanallmighty, Jun 8, 2015
I don't get it :/ It's irritating...I wish there was some guide out there from Google/LG on how to go about rectifying this.
 
#7 YaBoiSloopy, Jun 8, 2015
Yeah me to. Does yours show the logging in bit where you put your details in for a split second then goes to the no entry sign bit?
 
#8 Deanallmighty, Jun 8, 2015
I've added pics. To try n exain it to anyone who doesn't get me.

1) first click on the sign in then,

2) it loads and then then the no entry sign appears
 
#9 Deanallmighty, Jun 8, 2015
Yep, that sign plagues my life.
 
#10 YaBoiSloopy, Jun 8, 2015
Ah, you are missing a step
When you get the red sign, click on the 3 dots top right and select "Use this network as it is"
Then go to Chrome and access any site and you should be redirected to a sign on screen

Well this is what I do for open Wifi
 
#11 mistergoof, Jun 9, 2015
I'll give this ago when I'm back at the hotel but I think I've already tried this

Cheers
 
#12 Deanallmighty, Jun 9, 2015
Thanks for your help, will give this a try :)
 
#13 YaBoiSloopy, Jun 9, 2015
Tried it and I get this
 
#14 Deanallmighty, Jun 9, 2015
This is a hotel, they could be using a proxy to insert their own ads into webpages, and Chrome is determining that it could be a man-in-the-middle attack, which is basically what local ad insertion is. I've seen it before with hotel networks in China. A secure VPN would very likely fix it, that's what I use.

It's interesting that two people have come in about the same time, same problem, both Premier Inn. So probably it is something that this particular hotel chain has done with their network, like using an ad proxy.
 
#15 mikedt, Jun 9, 2015 Last edited: Jun 9, 2015
Sorry missed the last bit out.
Click ADVANCED
CLick on the Proceed link, this will take you to the open WiFi lpgon
 
#16 mistergoof, Jun 10, 2015
Just out of interest, John Lewis provides free WiFi without the need for a password.
However, in my experience, you can't connect to any competing retailers' web sites, clearly to prevent people 'price matching'!
Clever!
 
#17 JBentleyR, Jun 10, 2015
The premier inn WiFi is ran by an outside company called arqiva.

I've rang them previously but didn't get anywhere with them.

I'm currently at a premier inn this week so I can be a little test dummy . I'll try the above solution on the advanced section. Hope I can come up with something because it's doing my head in
 
#18 Deanallmighty, Jun 17, 2015
It didn't work unfortunately.
 
#19 YaBoiSloopy, Jul 28, 2015
So this issue wasn't resolved, perhaps someone technical at Premier Inn and/or Arqiva needs to become aware of it and needs t0 fix it.

Almost certain what it is, their proxy is manipulating SSL data packets, probably to insert ads, and Chrome is red-flagging it as a possible man-in-the-middle attack. Internet Explorer on Windows, which is probably what most people use, may not even be detecting this, nor Safari the default browser on Mac or iOS.


"Alice" is you with Chrome, "Bob" is Google's server, and "Mallory" is the Premier Inn or Arqiva proxy.

[​IMG]

https://en.wikipedia.org/wiki/Man-in-the-middle_attack
 
#20 mikedt, Jul 29, 2015 Last edited: Jul 29, 2015
Similar problem for me and same padlock screen.

I have a Moto g 4g running lollipop on O2. I live in Edinburgh.

Up until 2 weeks ago when travelling on the local Lothian bus network I have been able to connect and sign in to their Free Bus Wi-Fi with absolutely no problems.

However since 2 weeks ago their Wi-Fi is provided by LetsJoin

LetsJoin is a WiFi based infotainment network designed specifically for distribution on public transport nationally and since then although I can connect I am blocked from signing in. I get a white screen with a padlock inside a red circle. No amount of forgetting the network, switching on and off helps.

I have asked Lothian buses to investigate which they have agreed to do. I have no problem with other free Wi-Fi like M&S, Starbucks and others. My son's iPhone connects with no problems and I have checked with others using other manufacturer's phones. It appears to be a Moto issue.

Lothian Buses have promised to get their IT team to look at it and get back to me.

RogerB
 
#21 RogerBu, Aug 6, 2015
I posted earlier in this thread, I've actually seen this myself with hotel WiFi, with the HTTPS in the browser being marked in red as insecure, and that was with Chrome. That should just not happen, unless the data packets are being intercepted and modified by a proxy somewhere, It should be a completely encrypted secure connection over SSL between your browser and the web server. Possibly other Android webkit browsers might pick it up as well, like your Moto G browser, @RogerBu . I'm often using a VPN anyway, really because of where I am.
 
#22 mikedt, Aug 6, 2015 Last edited: Aug 6, 2015
I tried this too, but unfortunately it did not work on my phone either. Any solution?
 
#23 markK, Aug 6, 2015
Try a different browser, or better, use a VPN.
 
#24 mikedt, Aug 6, 2015
Thank you Mistergoof that did the trick. Exactly as you said. Although I didn't need the advanced bit. I still get the red sign but now at least I know how to bypass it.

I will say that these Tech forums, be it this one or any number of others are always so helpful. You can always be sure to find someone with an answer to your problem.
 
#25 RogerBu, Aug 6, 2015