Home Forum

Can't connect to 'Free Wi-fi' with an access page. Help!

I have recently left the Apple world (planned to ages ago but as long as everything still worked it was bareable as I'm a simple user). I recently acquired a Lenovo P8 a.k.a Tab 3 8 Plus (TB 8703F). It's seems great except one problem with accessing free (unsecured) WiFi controlled by an access page.
Normal secured WiFi fine: select the connection, enter the WPA2 password and away you go. But some free WiFi want you to login, i.e. it should connect but take you to a page where it wants some details, name, email and date of birth not uncommon particularly in a Pub. Trouble is is says I'm connected but doesn't take me to the login page so can't actually use it. On my phone (Lenovo P2) you select the same network it says 'connected, no internet' but also flashes up an Android Notification saying you need to login which, when you tap, takes you to the login page; put in your details and you're away. Not on the tablet, no notification and no means of getting to the login page as you have no functioning internet.
What am I missing? Looking through Settings I can see nothing obvious. The tablet came clean, a RoW spec.
I've asked the same question on the Lenovo forum but nothing, no help from either the community or Lenovo's so called help.... seems to me Lenovo don't care much about customer service once they have your money, shame as the tablet seems really good otherwise.
Has anyone had similar problems or knows a solution?
 

Related:

#1 slackermark, Feb 14, 2018
Once you are connected on the tab, just open a browser and try to go to any external website. It should first redirect you to the login page.
 
#2 lunatic59, Feb 14, 2018
This is 100% true I've done it my-self on many occasions

but NOTE:
Browser not google app
 
#3 Astr4y4L, Feb 14, 2018
Didn't do it last time but I will try again. I have the Google app (OK you say probably not going to work here) but I also have Chrome and Firefox and the login page doesn't come up on any of them. Should I download a different browser specifically for this and if so which one? Also does it need to be 'clean' i.e. no existing initial page? Thanks in advance. But still nice to know it should work just have to find the work around. I was assuming it was something to do with the necessary Android Notification being turned off but I'll chase the 'clean browser' route for a while. Like I said I can get on with the phone so not the end of the world just annoying. Cheers anyway. Any other suggestions please keep them coming. I will of course let you know when I have something that works consistently.
 
#4 slackermark, Feb 14, 2018
open the browser and type into the addreass bar.
http://www.google.com

plz note http not https
 
#5 Astr4y4L, Feb 14, 2018
Excellent point. Many places that provide free wifi may not be up to standard with securing their sites so the host wouldn't know what to do with traffic on port 443.

Look at you being all helpful and stuff. ;)
 
#6 lunatic59, Feb 14, 2018
The issue you're dealing with is referred to as a 'captive portal login', a sort of enhanced way to force a user to login into something like a public WiFi network. Essentially your tablet is connecting to this WiFi network, it's just that until you get past the captive portal login it won't allow you unfettered access to the Internet itself. Admittedly when compared to other operating systems Android appears to be somewhat lacking when dealing with captive portal logins. Read through the following to get a better background:
https://en.wikipedia.org/wiki/Captive_portal#Implementation

So you might not want to focus too much on just which browser to use, the problem isn't necessarily a browser-specific issue but more a matter of getting the Android OS on your tablet to actually get past that captive portal login process. The browser is just what you interact with directly, but there are things the hardware and OS are also dealing with beneath the user interface. That said, different browser apps do have different options in their own settings menus. Try perusing through yours to see if anything stands out. The Chrome app, as an example, has a 'Data Saver' option buried in its Settings, that if enabled you might want to try disabling to see if that makes a difference.
As a more generic step for any browser, at the very least dump the browser cookies and wipe its cache to see if that allows the captive portal login page to pop up properly.

But browser issues aside, try deleting that WiFi network entry in your Settings >> Wi-Fi menu. If this particular portal login was based on ICMP, it could have had a time limit set up where if you don't sign in within xx minutes it just won't let you in. If the login was based on DNS, you might want to try using a DNS changer app like this one:
https://play.google.com/store/apps/details?id=com.burakgon.dnschanger
This might at least allow you get that portal login page to show up again.

Another thing to try is if there's a 'Reset default networks' option buried in your Settings menu. On one of my phones it's in Settings >>Wireless & networks >> Wi-Fi in the little gear icon in the top menubar.
A more drastic measure is the 'Network settings reset' option (not sure about your Lenovo tab but in my phone it's in Settings >> Wireless & networks >> More) Just keep in mind this is kinda/sorta like a Factory Reset just for network settings. It will clear all your saved WiFi networks, any Bluetooth pairings you've set up, pretty much anything you've changed in your networking settings.
Wish I could make more definitive suggestions but there's just too many variables involved in this particular issue. Again, unless you ask whomever set up router and the captive portal, a possible solution is more a matter of experimentation on your part.
 
#7 svim, Feb 14, 2018
Very good info !
 
#8 Astr4y4L, Feb 14, 2018
Well I'm in guys, thank you for the help. Trouble is I don't know exactly what did the trick. I did go 'Settings', 'Apps', 'Google Play services', 'storage' then clear everything (manage space and the clear cache; maybe a sledgehammer but it's worked for me with other android 'quirks') and then tapped the Chrome app and up came the login page. I'm in which is fine...... now need to find another site/pub with similar 'captive portal login' to be sure. Thanks again.
 
#9 slackermark, Feb 16, 2018 at 1:39 PM Last edited: Feb 16, 2018 at 1:51 PM