Home Forum

Missing Google Play Store Icon

My son came to me with his Android tablet saying the play store icon had vanished. He was right. It's not on the home page or in the Apps drawer.

However it appeared to be still there according to Settings -> Apps. So I fired up the browser and went to the play store website the tablet asked me if I wanted to "complete that action using Play Store" (or words to that effect) and that worked just fine. So he can at least use the play store but getting there without an icon anywhere is a pain.

So I uninstalled play store and reinstalled it (version 4.1.10) and still no icon appeared.

Rebooting made no difference and there seems to be plenty of space/storage.

Anything else to try before I reset the thing to factory default and start over?



#1 CWatters, Jun 9, 2013
Clear data from which ever launcher(home app) you're using. You will have to set up all your home pages again but you will still have all your other app data.
#2 nicka3200, Jun 9, 2013
Thanks will give it a go.

Edit: Actually before I do that... I don't think the icon is anywhere else either so I'm not sure how I can add it the Home page when I come to set that up again.
#3 CWatters, Jun 11, 2013
Install ES File Explorer, its app manager is able to create shortcuts of "hidden" apps on the home screen.
Open ES's app manager (Tools, App Manager, System Apps ...), you'll find the Play Store app, and create a shortcut of it ...voila :)

#4 Harry2, Jun 11, 2013
A further suggestion (bearing in mind I'm not familiar with your device) is that when you open the app drawer is there a tiny play store icon at the top or is there a menu icon within the app drawer? On my Sense 4+ phone there is a play icon in that position & I've used launchers with a menu function which has the play store as one of the options.
#5 nicka3200, Jun 11, 2013
#6 cajun treasure, Jan 29, 2015
Hello, I had the same problem. I had the app turned off in Application Manager. Just go to settings, click on more, look for App. Manager, scroll until you see Play Store app and turn it on. Hope this helps.
#7 cajun treasure, Jan 29, 2015
#8 cajun treasure, Jan 29, 2015
I had the same problem. I had the app turned off and forgot I did it. Go to settings, more, Application Manager, scroll until you see Play Store, click on that app and make sure it is turned on. I hope this helps!
#9 cajun treasure, Jan 29, 2015
Welcome to the forums, cajun! :)
#10 EarlyMon, Jan 29, 2015
Yeah welcome cajun ;l
#11 funkylogik, Jan 29, 2015